Drug testing

Cisco CCNA / CCNP Certification: OSPF ASBRs Explained And Illustrated

When I first started studying for my CCNP, some of the concepts of OSPF really confused me. This was especially true for the ASBR, stub areas, and total stub areas. Sure, I could memorize the LSA types associated with these devices and area types, but there just weren't any illustrations that explained exactly what was going on.

This CCNP tutorial shows an ASBR in operation, and also introduces you to a basic example of route redistribution. Don't worry, it gets more complicated. :)

Here's the network we'll be working with in this tutorial:

R5

|

R1

/

R2 R3

Networks:

R1 - R5 Ethernet Segment: 10.1.1.0 /24

R1 - R2 - R3 Serial Segment: 172.16.123.0 /24 (Preconfigured with OSPF)

R1 and R5 are running RIP over their common Ethernet segment, 10.1.1.0 /24. R5 has three loopbacks it will be advertising into the RIP domain.

R1 is also running OSPF, with R2 and R3 as neighbors. Even though R1 knows about the loopbacks on R5, its OSPF neighbors do not. R1 has these routes in its RIP routing table, and for OSPF neighbors to learn of these routes, route redistribution must be manually configured.

R5#conf t
R5(config)#router rip
R5(config-router)#version 2
R5(config-router)#no auto-summary
R5(config-router)#network 5.0.0.0
R5(config-router)#network 10.0.0.0

R1#conf t
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#no auto-summary
R1(config-router)#network 10.0.0.0

R1#show ip route rip
5.0.0.0/24 is subnetted, 3 subnets
R 5.1.1.0 [120/1] via 10.1.1.5, 00:00:10, Ethernet0
R 5.2.1.0 [120/1] via 10.1.1.5, 00:00:10, Ethernet0
R 5.3.1.0 [120/1] via 10.1.1.5, 00:00:10, Ethernet0

R1 has a route for all three of R5's loopback interfaces, learned via RIP. R1 is also running OSPF, but its neighbors R2 and R3 don't know about these RIP routes:

R2#show ip route ospf

R2# < no output from show command means no routes! >

R3#show ip route ospf

R3#

Be careful when configuring redistribution use IOS Help to make sure you're not missing any vital options. IOS Help shows that there is a "subnets" option when redistributing RIP into OSPF. If that is left off, only classful networks are redistributed (as the router is kind enough to tell us). In this case, we have no classful networks, so there will be no redistribution. R2 will not see the RIP routes.

R1(config)#router ospf 1
R1(config-router)#redistribute rip ?

metric Metric for redistributed routes
metric-type OSPF/IS-IS exterior metric type for redistributed routes
route-map Route map reference
subnets Consider subnets for redistribution into OSPF
tag Set tag for routes redistributed into OSPF

R1(config-router)#redistribute rip
% Only classful networks will be redistributed

R2#show ip route ospf

R2#clear ip route *

R2#show ip route ospf

R2#

On R1, we'll now use the "subnets" option, and the RIP subnets are successfully redistributed into OSPF.

R1(config)#router ospf 1

R1(config-router)#redistribute rip subnets

R2 now sees the redistributed routes.

R2#show ip route ospf

5.0.0.0/24 is subnetted, 3 subnets

O E2 5.1.1.0 [110/20] via 172.12.123.1, 00:00:08, Serial0.123

O E2 5.2.1.0 [110/20] via 172.12.123.1, 00:00:08, Serial0.123

O E2 5.3.1.0 [110/20] via 172.12.123.1, 00:00:08, Serial0.123

10.0.0.0/24 is subnetted, 1 subnets

O E2 10.1.1.0 [110/20] via 172.12.123.1, 00:00:08, Serial0.123

Notice that the routes are marked as "E2". The E indicates that these are external routes these are routes that were learned by OSPF via redistribution.

Naturally, you'll want to ping these networks to make sure you have two-way communication. Even though the routes to these loopbacks are in the routing table, pings fail:

R2#ping 5.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 5.1.1.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

Keep this in mind when troubleshooting: It's not enough to have a route to a destination for pings to succeed there's got to be a path back. At this point, R5 doesn't know where the 172.12.123.0 network is, so there's no way the ping can get back. More route redistribution is necessary on R1.

Your first instinct may be to redistribute OSPF routes into RIP to make this work, but remember that the 172.12.123.0 /24 network isn't known to R1 via OSPF it's a directly connected network. We can redistribute connected networks into RIP to give R5 a route to 172.12.123.0 /24, which will give the ICMP packets a path back to R2, which will allow pings to succeed.

R1(config)#router rip

R1(config-router)#redistribute connected

R5#show ip route rip

1.0.0.0/32 is subnetted, 1 subnets

R 1.1.1.1 [120/1] via 10.1.1.1, 00:00:02, Ethernet0

172.12.0.0/24 is subnetted, 1 subnets

R 172.12.123.0 [120/1] via 10.1.1.1, 00:00:02, Ethernet0

R2#ping 5.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 5.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 68/69/76 ms

Performing this redistribution makes R1 an ASBR, as shown here with show ip ospf. This command even shows you what protocol(s) are being redistributed into OSPF.

R1#show ip ospf

Routing Process "ospf 1" with ID 1.1.1.1

Supports only single TOS(TOS0) routes

Supports opaque LSA

It is an autonomous system boundary router

Redistributing External Routes from,

rip, includes subnets in redistribution

Knowing exactly what the ASBR does and how to configure route redistribution are just a few of the many OSPF skills you'll need to earn your CCNP. Like any other Cisco skill, breaking a complex topic like OSPF down into smaller, manageable pieces is the best way to master these topics and pass the CCNP exams.

Keep watching The Bryant Advantage website for more free CCNA and CCNP tutorials!

To your success,
Chris Bryant
CCIE #12933
chris@thebryantadvantage.com

Chris Bryant, CCIE #12933, is the owner of The Bryant Advantage. The Bryant Advantage offers dozens of FREE CCNA, CCNP, and Home Lab tutorials and articles. The Bryant Advantage sells the world's most comprehensive CCNA Study Guide, and my exclusive Binary Math and Subnetting Mastery book. My CCNA Online Fast Track is the world's fastest-growing CCNA course. Get your CCNA and CCNP today at http://www.thebryantadvantage.com

In The News:

Skygazers will be treated to the “super snow moon,” on Feb. 19, the largest supermoon of 2019.
In November 2016, astronomers watched a young star some 1,500 light-years away from Earth belch out an explosion of plasma and radiation that was roughly 10 billion times more powerful than any flare ever seen leaving Earth's sun. This sudden stellar eruption may be the most luminous known flare ever released by a young star — and it could help scientists better understand the still-murky process of star formation.
An audacious attempt to find explorer Sir Ernest Shackleton’s ship Endurance has been called off after the expedition team lost an undersea drone beneath Antarctic ice.
“Our wish is to fly this year,” NASA official Thomas Zurbuchen said at the surprise announcement of a new Moon mission overnight. “We want to incentive speed … We want to start taking shots on goal.”
Bones recently found in a Siberian cave have given researchers a new glimpse into the timeline of an extinct human species. The species – known as Denisovans – at one time lived alongside Neanderthals in the same cave, the evidence showed.
NASA's Opportunity Rover has died on Mars.
A rare 12th-century triple toilet seat will be going on display at a London museum later this year.
Ex-baseball player Jose Canseco has officially joined the group that believes "the truth is out there" and is on the hunt for UFOs and Bigfoot. 
MILAN (AP) — Archaeologists have discovered a fresco in an ancient Pompeii residence that portrays the mythological hunter Narcissus, who fell in love with his own reflection.
It’s a river unlike any in Australia — and a fortnight ago it barely existed.

Some Thoughts on Choosing a Flash MP3 Player

Flash mp3 players come with an exciting array of features,... Read More

SOBIG.F Virus Promises Ill Be Back

On 21 August 2003 Symantec Security Response upgraded the W32.SOBIG.F... Read More

10 Time Saving Keyboard Shortcuts

Time is money. And when you constantly have to divide... Read More

Troubleshooting Computer Freeze (Lockup) Problems

How familiar does the following sound? Your computer was working... Read More

Is Your Web Browser Putting You At Risk?

It's free, it comes with Windows and it's used by... Read More

How to Buy a Plasma Television Set

Most people think that all you have to do to... Read More

Classification of Computers

Computers are available in different shapes, sizes and weights, due... Read More

Home Electronics: The Facts About Plasma TV

Not so many years ago, homes across the country watched... Read More

CCNA 640-801 Certification Primer

The Cisco Certified Network Associate (CCNA) Certification is meant for... Read More

Review of Rio MP3 Players

Below you will find some useful information and comments about... Read More

How To Have Two (Multiple) Copies Of Windows

Having two operating systems is not as difficult as many... Read More

7 Reasons NOT to Take Your Laptop on Holiday!

Heading off on vacation soon?Then perhaps you're tempted to take... Read More

A Peek Into the Near Future of Electronics Technology

How long do you think DVDs have around? 20 years?... Read More

Deleting and Destroying Data Forever

Peoples' private information needs to stay private, even after it... Read More

Image Conversion In Computers

JPEG, GIFF/JIFF, BMP, and TIFF are the most commonly used... Read More

Be Prepared in the Event Computer Disaster Strikes

ComputersBusinesses and individuals alike have all grown to rely on... Read More

Cisco Certification: Taking Your First Certification Exam

You???ve studied hard; you???ve practiced your configurations; you???ve used your... Read More

Favorite Things To Do With Home Technology

Save money. Save 10-15% on utility bills per month. Work... Read More

Tips For Finding Great Deals On Computer Accessories & Supplies

Tip #1. Do a Google search. Don't be to general... Read More

This Page Cannot Be Displayed ? What to Do When Your Internet Breaks

The DNS (Domain Name System) servers are what your computer... Read More

Learning To Navigate Ciscos Online Documentation

When studying for your Cisco CCNA, CCNP, or CCIE exam,... Read More

Registry Tools Demystified

Not sure what Windows registry is or how it works?... Read More

5 Steps to Removing PC Clutter

It's hard enough as it is these days to get... Read More

Dynamite Comes in Small Packages - Tiny Personal Audio MP3 Players Pack Powerful Music Enjoyment

MP3 players are Hot! Playing music has come a long... Read More

The Benefits of Open Source

If you are a building a website or a forum,... Read More

broken street light led manufacturer in usa Pete's produce ..